TGViewer
Channel Public Channel
Патчкорд

Патчкорд

@patchcord

Блог сетевого инженера. Новости телеком, IT и около IT. Связь - @UrgentPirate
Subscribers
2.91K
Photos
275
Videos
23
Links
3.4K

Showing posts older than #2634 · Back to latest

Older Posts 20 shown
Post #2633 1.04K
SLA хорошая штука, если вы об этом сразу подумали и включили именно то что для вас важно, а не только пинги и джиттер, которые к тому же не договорились как измерять. Если включили, то второй момент включить значимые последствия за неисполнения этих показателей провайдером, а то параметры не выполняются, а добиться компенсации невозможно или это приводит к очень долгим переговорам. И третий момент, если на это всё провайдер согласился чтобы сумма которую он озвучил за все ваши хотелки оказалась вам по карману.
Если нет, часто стандартный договор не включает ничего, а расширенный только пинги с пределами из которых не выйдешь даже после атомного взрыва, то лучше принять что провайдер вещь ненадёжная и заиметь второго, предварительно проверив что он не арендует услуги у первого. Потому набить шишек, поругаться, сменить провайдера, сменить второго провайдера, поругаться ещё раз и ещё раз, задуматься о третьем, посчитать бюджет и может быть вернуться к полноценному SLA с тем кто уже есть, а третьего всё равно подключить. Если конечно ваши реальные потребности стоят этого.
Networking Beyond metrics, network SLAs should measure business ops Find out how to craft a comprehensive network service-level agreement that reflects end-to-end service quality and supports business outcomes.
  • 👍 5
Post #2632 647

Forwarded from linkmeup

Самому важному дистрибутиву современности сегодня стукает 30 лет.
По этому поводу даже пьянки в нескольких города самоорганизовываются.
https://wiki.debian.org/DebianDay/2023
P.S. Неделей ранее сусе стукнуло 18. Но кого это заботит вообще.
  • 👍 14
Post #2631 772
Наверное, со всей этой чехардой с RedHat и Centos, я опять вернусь к Debian, собственно на WSL у меня и так Debian, которая на фоне очень многих других выглядит незыблимо. Хороший повод отметить сегодняшний день.
  • 👍 1
Post #2630 874
Если сравнивать в лоб чистый L2 сдобренный STP и LACP с VXLAN сдобренным EVPN, то VXLAN выглядит лучше. Конечно если вы сначала построили хорошую L2 сеть с LACP и STP, сверху хорошую IP сеть с ECMP и миллисекундной сходимостью, а потом вам опять понадобился L2, который уже можно построить с использованием VXLAN. И это всё к вопросу и желанию связывать все устройства со всеми напрямую и на любые расстояния, упрощая последний уровень абстракции для конечного потребителя (видимо программистов), но не всю конструкцию целиком.
А чтобы не быть голословным и о чём мне напомнил наш читатель, посмотрите на RFC 7980 и книгу https://www.amazon.com/Navigating-Network-Complexity-Next-generation-virtualization/dp/0133989356, то что вы возможно пропустили в предыдущем посте про сложность.
Telegram Патчкорд Являются ли сети сложными? О, да. Дело конечно не в консоли, это всего лишь интерфейс и будь у производителей воля отойти от стандартных Cisco или Juniper стилей (нет, не как это сделали в Mikrotik) то и в ней можно было бы избавиться от бесконечных повторений…
  • 👎 1
Post #2629 798
Я недавно прочитал книжку про переговоры из серии популярно и поверхностно про бизнес, но эта книга изменит ваше представление о мире. Там обычно много личных примеров вперемешку с нужными психологическими исследованиями и практиками известных компаний, которые подтверждают мысль автора. Я даже с ней согласился во многом, хотя с такой литературой в духе КО, сложно не соглашаться. Так вот одним из постулатов там был: "Не идите на компромиссы, лучше не совершать сделку чем пойти на обоюдные уступки. Обе стороны в этом случае окажутся в проигрыше". Поэтому вот вам попытка сформулировать основную теорему инженерии - всё компромисс :) и в этом случае с автором тоже сложно не согласится.
ivymike.dev The Fundamental Theorem of Engineering: Everything's a Tradeoff - IvyMike.dev The Fundamental Theorem of Engineering: Everything's a tradeoff A runaway trolley is about to create 5 trolley problems. Do you pull the lever and divert it, so it only creates 1?...
  • 👍 2
Post #2628 865
Являются ли сети сложными? О, да. Дело конечно не в консоли, это всего лишь интерфейс и будь у производителей воля отойти от стандартных Cisco или Juniper стилей (нет, не как это сделали в Mikrotik) то и в ней можно было бы избавиться от бесконечных повторений и накручивании связей вручную. Собственно, описанные в статье интерфейсы это и делают вываливая тысячи стандартных консольных команд скрывая их за политиками и объектами.

Сложность сети - в самой сети, топологии. Как только любое устройство напрямую сможет передать любое количество данных любому другому устройству в любое другое место за бесконечно короткое время, тогда сети станут простыми. А пока это не так и приходится думать как и что передать даже в пределах одного облака, одного ДЦ, одного офиса - думать о сети, а думать всегда сложно.
Cloudtrooper Is Computer Networking too complex? This question has been bothering me for quite some time now. Other technology areas constantly look to reduce complexity: take for example one of the most difficult fields out there, data science. …
  • 👍 7
Post #2626 1.11K
Инструменты чем "тестировать" firewall и для МСЭ подойдёт. У меня конечно есть вопросы к некоторым пунктам, что там имелось ввиду и какой firewall должен от всего этого уметь защищать, но оценить свой сетевой периметр по этому списку, с учётом вашей паранойи, подойдёт.
  • 👍 3
Post #2625 847
В Ираке начали блокировать Telegram для чего использовали BGP, а мы узнали об этом потому что маршруты протекли во вне. Но у Telegram все маршруты подписаны, ну почти, поэтому ничего масштабного за пределами Ирака не произошло. Анонсировать чужие префиксы всему миру - не очень, один провайдер на всю страну - тоже не очень, а вот подписывать свои префиксы - рабочий инструмент, в статье этому ещё один пример приводится с Twitter.
Kentik Iraq Blocks Telegram, Leaks Blackhole BGP Routes This past weekend, the government of Iraq blocked the popular messaging app Telegram, citing the need to protect Iraqi’s personal data. However, when an Iraqi government network leaked out a BGP hijack used for the block, it became yet another BGP incident…
  • 👍 5
Post #2624 1.4K
Post #2623 999
Про Сноудена кстати нет, но зато про него, точнее про последствия его действий есть целый совсем недавно принятый RFC9446 и его презентация в блоге APNIC. Это не RFC в привычном смысле в нём собраны мнения 4-х людей: Bruce Schneier, Stephen Farrell, Farzaneh Badii и Steven M. Bellovin - на те события и сегодняшний мир после них.
APNIC Blog Ten years after: What's changed since Snowden? | APNIC Blog IETF draft shares four different personal observations, reflections, and insights made since the leak.
  • 👍 2
Post #2622 942
Вехи развития компьютерной науки, или вообще компьютеров и всё что в это понятие в принципе можно вложить, с очень давних времён. Автор конечно определяет правила по которым составлялся список, но получилось всё равно в разнобой, от науки и индустрии до общественно-политических событий. В любом случае, можно сверится со своей внутренней временной шкалой, когда и что было изобретено.
Shtetl-Optimized Timeline of computer science Update (Feb. 14): Thanks so much to the many commenters who offered suggestions—I’ve implemented a large fraction of them! In addition to many clarifications and corrections of existin…
  • 👍 2
Post #2621 994
Видеоуроки по OSPF для начинающих и любителей видео формата. Разбирается достаточно подробно, включая LSA, иначе бы зачем тогда.
  • 👍 7
Post #2620 1.02K
Cloudflare добавили на свой радар статистику по BGP - https://radar.cloudflare.com/routing, с упором на проблемы: утечки и перехваты. Есть в разрезе по странам, по автономкам, по префиксам. Кстати, количество IPv4 префиксов они видят больше миллиона.
Cloudflare Routing Information Worldwide | Cloudflare Radar Global BGP routing trends and insights, including statistics and detected routing anomalies.
  • 👍 4
Post #2619 1.14K
Разбор питоновского "Hello World" в глубину в Linux по шагам, начиная от обработки командной строки shell и заканчивая системным библиотечным write(). Есть про файловую систему, формат исполняемых файлов, библиотеки, системные вызовы, процессы с примерами использования утилит strace, stat, ldd и некоторых других. Тот случай, когда сишный "Hello World" выглядел бы немного попроще.
Julia Evans Behind "Hello World" on Linux Today I was thinking about – what happens when you run a simple “Hello World” Python program on Linux, like this one?
  • 👍 6
Post #2617 890
Собрать коалицию, чтобы помочь решать проблемы безопасности сетевых устройств мысль может и хорошая. Но те кто пытается следить за безопасностью, прекрасно знают что патчи безопасности для сетевых устройств выходят почти ежемесячно, иногда чаще, а поддержка даже очень хороших устройств прекращается на редкость быстро и в какой-то момент, если не гнаться за маркетингом, ты остаёшься один на один с функциональным устройством с уязвимостями. Причём далеко не с одним, очень далеко не с одним, что само по себе проблема даже имея поддержку от производителя иметь на них актуальные версии прошивок. А за рамками этой поддержки или после того как производитель вывел устройства в устаревшие можно только принять риски, спрятать их подальше в сети и скрестить пальцы на удачу.
  • 👍 6
Post #2616 911
Если бы меня вчера спросили: "Стоит ли заняться IPv6?" - я бы ответил: "Этим стоило заняться ещё вчера". Но если вы займётесь им сегодня, то вы не опоздаете. Порой кажется процесс перехода на IPv6 не завершится никогда, я не думаю что это так. К сожалению, даже современные вещи, в современных окружениях, плохо уживаются с IPv6 о чём эта история переезда сайта на IPv6 only внутри которой есть небольшое интервью с Kasper Dupont автором nat64.net.
matduggan.com IPv6 Is A Disaster (but we can fix it) IP addresses have been in the news a lot lately and not for good reasons. AWS has announced they are charging $.005 per IPv4 address per hour, joining other cloud providers in charging for the luxury of a public IPv4 address. GCP charges $.004, same with…
  • 👍 3
Post #2615 967
Пока у меня за окном жаркий пятничный вечер напомню, что уже 6 лет существует этот канал и за этот год здесь оказалось 341 сообщение по очень грубому счёту, включая все репосты и серии сообщений потому что в одно не поместился. И это больше чем в прошлом году, что меня прямо сильно удивило, потому что по ощущениям казалось получалось писать реже и меньше. Я так не поверил что даже перепроверил прошлый год и этот год снова. Вот для чего нужен именно этот скучный пост :) - для объективного взгляда со стороны, чтобы немного взбодриться, вдохновиться и продолжить этот забег на длинную дистанцию, обязательно с вашей поддержкой.

В этот раз наибольшее внимание обратили на себя:
- RFC9293 с TCP внутри
- Анимация про то как кончается IPv4
- И ASCII календарик на 2023 год с котиком-сетевиком

Реакции я снова посчитал вручную, потому что в API Telegram Bot, если я не ошибаюсь, всё ещё нет такой возможности. Палец вверх:
- Не TCP протокол, зато наш
- Кровавый энтерпрайз как он есть
- Мой Flipper, имя которого я никому не сказал
- И ещё один RFC791 на русском в переводе Linkmeup

Пальцы вниз:
- Yandex со своим post mortem
- Perl, который живее всех живых
- и опасные эксперименты с 220 на батарею

@FullViewBGPbot, @bgp_table_bot и https://host-correct.ru тоже остаются в строю. Для первого я добавил графиков, второй переехал на Mastodon, а третий, правда не очень удачно, на Unbound.

Я опять борюсь с Twitter который на этот раз сломал его собственный хозяин - перемешав IPv6 с облачным хостингом, срезав трафик через Tor и разогнав ощутимое количество авторов в разные стороны, что сказалось на наполняемости моей новостной ленты, которую можно комментировать для вас.

Продолжаем бежать дальше, большое спасибо что бежите вместе со мной!
  • 👍 19
  • 👎 1
Post #2614 888

Forwarded from Ш&М

Роутер

Автор: Grad 916
Адрес: г. Екатеринбург, Вторчермет (56.762695° 60.577451°)

👉 Ш&М
  • 👍 12
Older posts →
Threads Profile ViewerView any public Threads profile without an account.Open ThreadLook →Writing with AI? Make it sound human.Metric37 rewrites AI drafts so they read naturally. Free AI detector, 1,500 words free.Try Metric37 →