Авторская информация о системном администрировании.
Информация о рекламе: @srv_admin_reklama_bot
Автор: @zeroxzed
Второй канал: @srv_admin_live
Сайт: serveradmin.ru
Ресурс включён в перечень Роскомнадзора
Post #5734
7.63K

В последнее время видел много упоминаний на тему загрузки на старом ядре Linux, если после обновления на новом возникают проблемы. Это стало особенно актуально после перехода PVE на новое ядро 7-й версии. На некотором железе с ним возникают проблемы. Я сам с этим столкнулся на одном из серверов. Хотя чаще всего всё в порядке.
На эту тему я вспомнил свою старую историю на этот счёт, когда пришлось откатиться на старое ядро, чтобы восстановить работоспособность сервера. История редкая, я не слышал, чтобы кто-нибудь о подобном рассказывал, но я столкнулся лично.
Была у меня одна виртуалка с веб сервером, которая начала глючить из-за нехватки памяти. Периодически приходил OOM Killer и выключал Mysql. У неё был большой аптайм, так что решил её на всякий случай перезагрузить, прежде чем разбираться с тем, почему перестало хватать памяти. Ну и чтобы не приседать два раза, решил сразу и обновления свежие поставить.
Во время обновления пакетный менеджер ругнулся на нехватку памяти и не закончил нормально свою работу. Думаю, ладно, перезагружу, как есть, без обновлений. Перезагружаю, а система не стартует. В консоли ошибка:
Не буду рассказывать, как я её решал, чтобы не тратить понапрасну ваше время. Перехожу сразу к сути. Пакетный менеджер установил все обновления, в том числе ядра. В момент пересборки initramfs с новым ядром, процесс с
Решилось это выбором старой версии ядра для загрузки системы. Для него initramfs был собран нормально. Загрузился на старом ядре, ещё раз нормально провёл обновление и убедился, что всё в порядке. От подобной ошибки, кстати, частично страхует наличие swap, хоть и не на 100%. У меня обычно везде есть swap, но тут он не помог.
Всё это было ещё в те времена, когда LLM не работали как доступные публично персональные помощники, к которым можно было обратиться с вопросом. Пришлось разбираться самому. Не знаю, насколько сейчас всё это актуально, но если вы не знаете, что такое initramfs и как загружается система Linux, посмотрите мою заметку на этот счёт. Думаю, что на собеседованиях эта тема по-прежнему может быть актуальной. Да и просто, когда знаком с базой, решение ошибок сильно упрощается.
p.s. Картинка снизу не моя, нашёл в инете для наглядности. Она примерно так и выглядит. Когда первый раз видишь подобное, становится не по себе, так как выглядит страшно и не понятно, как решать. Сразу о бэкапах начинаешь думать и хаотично вспоминать, точно ли с ними всё в порядке.
———
ServerAdmin: 📱 Telegram | 🌐 Сайт | 📲 MAX 😩
#linux #ошибка
На эту тему я вспомнил свою старую историю на этот счёт, когда пришлось откатиться на старое ядро, чтобы восстановить работоспособность сервера. История редкая, я не слышал, чтобы кто-нибудь о подобном рассказывал, но я столкнулся лично.
Была у меня одна виртуалка с веб сервером, которая начала глючить из-за нехватки памяти. Периодически приходил OOM Killer и выключал Mysql. У неё был большой аптайм, так что решил её на всякий случай перезагрузить, прежде чем разбираться с тем, почему перестало хватать памяти. Ну и чтобы не приседать два раза, решил сразу и обновления свежие поставить.
Во время обновления пакетный менеджер ругнулся на нехватку памяти и не закончил нормально свою работу. Думаю, ладно, перезагружу, как есть, без обновлений. Перезагружаю, а система не стартует. В консоли ошибка:
Kernel panic not syncing: VFS: Unable to mount root fsНе буду рассказывать, как я её решал, чтобы не тратить понапрасну ваше время. Перехожу сразу к сути. Пакетный менеджер установил все обновления, в том числе ядра. В момент пересборки initramfs с новым ядром, процесс с
update-initramfs упал из-за нехватки памяти и начальный загрузчик не собрался. Но в Grub по умолчанию было назначено новое ядро. В итоге система не стартовала.Решилось это выбором старой версии ядра для загрузки системы. Для него initramfs был собран нормально. Загрузился на старом ядре, ещё раз нормально провёл обновление и убедился, что всё в порядке. От подобной ошибки, кстати, частично страхует наличие swap, хоть и не на 100%. У меня обычно везде есть swap, но тут он не помог.
Всё это было ещё в те времена, когда LLM не работали как доступные публично персональные помощники, к которым можно было обратиться с вопросом. Пришлось разбираться самому. Не знаю, насколько сейчас всё это актуально, но если вы не знаете, что такое initramfs и как загружается система Linux, посмотрите мою заметку на этот счёт. Думаю, что на собеседованиях эта тема по-прежнему может быть актуальной. Да и просто, когда знаком с базой, решение ошибок сильно упрощается.
p.s. Картинка снизу не моя, нашёл в инете для наглядности. Она примерно так и выглядит. Когда первый раз видишь подобное, становится не по себе, так как выглядит страшно и не понятно, как решать. Сразу о бэкапах начинаешь думать и хаотично вспоминать, точно ли с ними всё в порядке.
———
ServerAdmin: 📱 Telegram | 🌐 Сайт | 📲 MAX 😩
#linux #ошибка
- 👍 61
- 👎 1













