🟡 Причина: Закончилась квота минут на использование Managed Runners, были остановлены все расчеты и сборки
Использовал базовую VM в Я.Облаке (это совсем недорого).
🟡 Шаги предельно просты:
— Download the latest runner package
— Extract the installer
— Create the runner and start the configuration experience
— Last step, run it!
🟡 Трудности с которыми столкнулся:
— Все тулы нужно поставить на VM самостоятельно (либо взять boot disk за основу): Docker, git, curl, etc.
— Права. Нужно выдать права на чтение, запись и запуск (rwx), ловил ошибки, пока не выдал необходимые права
buildx failed with: ERROR: permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get "http://%2Fvar%2Frun%2Fdocker.sock/_ping": dial unix /var/run/docker.sock: connect: permission denied
— После завершения SSH-сессии, runner становится недоступен. Процесс нужно запустить как сервис через systemd. Configuring the self-hosted runner application as a service
🟡 В итоге:
— Имеем всю мощь Github Actions и набор поддерживаемых фичей
— Богатство решений и автоматизаций в Marketplace
— С замечательной документацией
— В качестве отличной замены динозаврам automation server типа Jenkins (и прочим подобным тулам)
— По цене базовой виртуалки
◻️ До сих пор используете Jenkins?
🌐 @data_apps | Навигация по каналу


