TGViewer
infosecurity infosecurity @tg_infosec · 26.8K subscribers
Post #2251 6.24K
infosecurity Photo
📶 Как SSH появился на 22 порту.

• SSH по умолчанию работает на порту 22. Это не совпадение. Вот история, как ему достался этот порт.

• Когда Tatu Ylonen (создатель SSH и генеральный директор компании SSH Communications Security) впервые опубликовал эту историю в апреле 2017 года, она стала вирусной: её прочитали около 120 000 читателей за три дня. Дальше идёт повествование с его слов:

• Я написал первую версию SSH (Secure Shell) весной 1995 года. В то время широко использовались Telnet и FTP.

• Но я всё равно разработал SSH для замены и telnet (порт 23) и ftp (порт 21). Порт 22 был свободен и удобно располагался между портами для telnet и ftp. Я подумал, что такой номер порта может стать одной из тех маленьких деталей, которые придадут некоторую ауру доверия SSH. Но как его получить? Я никогда не распределял порты, но я знал тех, кто этим занимается.

• В то время процесс выделения портов был довольно простым. Интернет был меньше, и мы находились на самых ранних стадиях интернет-бума. Номера портов выделяла организация IANA (Internet Assigned Numbers Authority). В то время это означало уважаемых первопроходцев интернета Джона Постела и Джойс К. Рейнольдс. Среди всего прочего, Джон являлся редактором таких незначительных протоколов, как IP (RFC 791), ICMP (RFC 792) и TCP (RFC 793). Возможно, кто-то из вас слышал о них.

• Меня откровенно пугал Джон как автор всех основных RFC для Интернета!

• Так или иначе, но перед анонсом ssh-1.0 в июле 1995 года я отправил в IANA электронное письмо с описанием преимуществ своего протокола и просьбой выделить для него порт 22. И на следующий день мне пришёл ответ с официальным закреплением порта 22 за SSH.

• У нас получилось! Теперь у SSH порт 22!!!

• 12 июля 1995 года в 2:32 утра я анонсировал окончательную бета-версию для своих бета-тестеров в Хельсинкском технологическом университете. В 17:23 выслал тестерам пакеты ssh-1.0.0, а в 17:51 отправил объявление о SSH (Secure Shell) в список рассылки cypherpunks@toad.com. Я также продублировал анонс в несколько новостных групп, списков рассылки и непосредственно отдельным людям, которые обсуждали смежные темы в интернете.

#Разное
  • ❤ 38
  • 🔥 19
  • 👍 14
More from @tg_infosec
  1. Oct 14, 2026📚 Effective Shell - неплохой учебник по работе в командной строке Linux. От базовых опера…
  2. Oct 14, 2026Гонка с эксплойтами: подключаем AI-агента По данным VulnCheck, 28,96% уязвимостей из KEV з…
  3. Oct 13, 2026🖥 Windows 3.1 • 34 года назад была выпущена Windows 3.1 (изначально носившая кодовое имя…
  4. Oct 13, 2026• Интернетизация... • Журнал Хакер - Спец. выпуск №7 - 2002 год. #Разное
  5. Oct 13, 2026Примите участие в исследовании инсайдерских рисков российского бизнеса Как российские комп…
  6. Oct 12, 2026🫠 Кибератака на холодильники... • В ночь с 11 на 12 октября во Франции произошел инцидент…
Threads Profile ViewerView any public Threads profile without an account.Open ThreadLook →Writing with AI? Make it sound human.Metric37 rewrites AI drafts so they read naturally. Free AI detector, 1,500 words free.Try Metric37 →