Как известно, после недавнего большого падения облако Битрикс24 переехало в немецкий датацентр AWS.
После этого у нескольких моих клиентов и у меня на тестовом стенде штатный обмен товарами и счетами периодически стал падать то с ошибкой "Не удалось получить данные с сервера", то "Не удалось установить соединение с сервером https://example.bitrix24.ru".
Ошибка плавающая - то обмен ломался, то снова начинал работать. Воспроизводится на платформе во всех версиях УТ 11.3 при работе на платформе 1С:Предприятие 8.3 (проверил в том числе на актуальном на сегодня релизе 11.3.4.185). В 11.4 ошибка исправлена (проверил на актуальном 11.4.2.139).
Кратко о причине: ошибка в сигнатуре конструктора объекта
HTTPСоединение при установке соединения для обмена, которая проявилась на фоне предположительно увеличевшегося пинга до портала в связи с переездом облака в другой ДЦ.Подробнее о причине ошибки и код для исправления - по ссылке: https://kuntashov.ru/b24/httpconn.html