TGViewer
Об ЭП и УЦ Об ЭП и УЦ @ep_uc · 21.4K subscribers
Post #5696 2.15K
✍️PKCS#7 отменить нельзя оставить (поставьте запятую, где считаете нужным)

Простой поиск выдаёт десятки нормативных актов, содержащих формат подписи PKCS#7. Почему так получилось? Кто-то первым написал, другие бездумно скопировали.

В перечне и постановление Правительства с
Наличие на электронном документе одной или нескольких усиленных квалифицированных электронных подписей, исполненных в формате отделенной электронной подписи (PKCS#7) должностными лицами органа, выдавшего исполнительный документ.

а также приказы ФНС, ФССП, Судебного департамента, Минюста, СФР, метод.рекомендации ЕСИА и др.

PKCS#7 был разработан в 1991 году и в 1998 стал стандартом в рамках RFC 2315. Но уже в 1999 году на его основе разработан формат CMS и утвержден RFC 2630, актуальная версия CMS в настоящее время утверждена RFC 5652 в 2009 году.

CMS - эволюционное развитие PKCS#7: та же базовая структура SignedData, но с исправлениями для гибкости, однозначности кодирования и поддержки современных алгоритмов (включая российские ГОСТ). Именно поэтому 472 приказ Минцифры ссылается на CMS, а не на PKCS#7 (если бы не известные ошибки).

✍️"Об ЭП и УЦ"
More from @ep_uc
  1. Oct 13, 2026📣Сертификаты безопасности для доменов Google и YouTube были выданы двумя центрами сертифи…
  2. Oct 13, 2026Злоумышленники получили фейковые TLS-сертификаты для Google и других сервисов #DNS #взлом…
  3. Oct 13, 2026Post #5698
  4. Oct 11, 2026Об электронной подписи - что, если... ? Исторический пост "Что, если…?- мультфильмы от Mar…
  5. Oct 10, 2026❌С выписками есть проблемы Озвученная на форуме КриптоПро проблема - довольно серьёзная. П…
  6. Oct 10, 2026Post #5689
Threads Profile ViewerView any public Threads profile without an account.Open ThreadLook →Writing with AI? Make it sound human.Metric37 rewrites AI drafts so they read naturally. Free AI detector, 1,500 words free.Try Metric37 →