Nginx: 502 Bad Gateway - Пять причин и решений
502 Bad Gateway обычно возникает, когда Nginx работает, как обратный прокси-сервер и не может подключиться к серверным службам. Это может быть связано со сбоем службы, сетевыми ошибками, проблемами конфигурации и т.д. Рассмотрим пять основных причин возникновения этой ошибки и то, как их исправить.
https://www.dev-notes.ru/articles/devops/nginx-502-bad-gateway/
Post #339
16